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According	to	an	old	rule	of	thumb,	your	page	file	or	swap	should	be	“double	your	RAM”	or	“1.5x	your	RAM.”	But	do	you	really	need	a	32	GB	page	file	or	swap	if	you	have	16	GB	of	RAM?	You	probably	don’t	need	that	much	page	file	or	swap	space,	which	is	a	relief	considering	a	modern	computer	might	have	a	solid-state	drive	with	very	little	space.	The
Purpose	of	the	Page	File	or	Swap	Partition	RELATED:	What	Is	the	Windows	Page	File,	and	Should	You	Disable	It?	First,	let’s	remember	the	real	purpose	of	the	page	file	on	Windows	or	swap	partition	on	Linux.	Both	provide	additional	working	memory	to	your	computer.	For	example,	if	your	computer	has	2	GB	of	RAM	and	you	open	a	large	number	of
programs	or	large	number	of	files,	your	computer	might	need	to	store	3	GB	of	data	in	its	working	memory.	The	computer	stores	that	additional	1	GB	of	data	in	its	page	file	or	swap	space.	The	page	file	or	swap	acts	as	an	“overflow”	area	to	hold	the	additional	data.	Your	computer	automatically	transfers	data	back	to	its	RAM	when	it’s	being	used,	and
moves	data	to	its	page	file	or	swap	partition	when	it’s	not	being	used.	If	you	used	an	older	desktop	computer,	you	could	see	this	happen	after	you	minimized	a	desktop	program	for	a	while.	When	you	maximized	it	later,	it	would	take	a	while	to	appear,	and	you’d	hear	your	hard	drive	grinding	away	while	that	disk	activity	LED	flashed	—	its	data	was
being	moved	back	from	your	page	file	or	swap	partition	to	its	RAM.	The	RAM	is	much	faster	than	the	page	file	or	swap	partition.	(This	is	much	less	common	on	modern	computers	that	have	sufficient	amounts	of	RAM	to	keep	desktop	programs	in	RAM.)	Most	applications	expect	to	get	the	memory	they	request.	If	your	RAM	was	full	and	you	had	no	page
file,	and	then	you	opened	another	program,	the	program	would	likely	crash.	Having	a	page	file	with	additional	space	programs	can	use	prevents	this	from	happening.	Other	Uses	for	Page	File	and	Swap	Partitions	Windows	and	Linux	also	use	their	page	file	and	swap	space	for	other	purposes:	Windows	Crash	Dumps:	On	Windows,	the	page	file	is	used
for	crash	dumps.	To	create	a	complete	memory	dump,	the	page	file	must	be	at	least	the	size	of	the	physical	memory	+	1	MB.	For	kernel	memory	dumps,	the	page	file	must	be	at	least	800	MB	on	systems	with	8	GB	of	RAM	or	more.	Most	people	won’t	need	complete	memory	dumps,	but	kernel	dumps	might	be	useful.	The	required	800	MB	page	file	is
fairly	small,	but	it	requires	you	leave	your	page	file	enabled	and	don’t	disable	it.	(This	information	is	taken	from	the	Understanding	Crash	Dumps	post	at	Microsoft	TechNet.)	Linux	Hibernation:	On	Linux	systems,	hibernate	—	the	power-down	state	that	saves	the	contents	of	your	system’s	RAM	to	disk	so	it	can	be	reloaded	when	you	boot	up	again	—
saves	the	contents	of	the	system’s	RAM	to	the	swap	partition.	This	may	also	be	referred	to	as	“suspend	to	disk.”	You	might	assume	you	need	a	swap	partition	as	big	as	your	RAM	to	hibernate	to	it,	but	you	actually	just	need	a	swap	partition	as	big	as	the	RAM	you	use	—	so,	if	you	only	regularly	use	4	GB	of	your	16	GB	of	RAM,	you	could	hibernate	to	a	4
GB	swap	partition.	However,	if	you	used	more	than	4	GB	of	RAM,	you	might	not	be	able	to	hibernate.	It’s	often	safe	to	choose	a	swap	partition	equal	to	the	size	of	your	RAM.	Note	that	this	only	applies	to	hibernating	—	if	you	never	plan	on	hibernating	your	computer,	you	don’t	need	to	worry	about	this.	(Windows	hibernates	by	saving	data	to	the
C:\hiberfil.sys	file,	so	the	page	file	isn’t	involved	when	hibernating	on	Windows.)	The	Real	Question:	How	Much	Memory	Do	You	Use?	There’s	no	one	hard-and-fast	rule	that	will	tell	you	how	much	paging	or	swap	space	you	need.	The	answer	depends	on	what	you	do	with	your	computer	and	how	much	memory	you	use.	For	example,	if	you	have	8	GB	of
memory	but	you	never	ever	used	more	than	those	8	GB,	you	could	get	by	with	no	paging	or	swap	space	at	all	—	it’s	likely	you	would	need	more	than	8	GB	eventually,	of	course.	On	the	other	hand,	you	might	have	a	computer	with	64	GB	of	memory,	but	it	might	regularly	work	with	100	GB	data	sets	—	you’d	probably	want	at	least	the	64	GB	paging	or
swap	space	just	to	be	safe.	So	a	computer	with	8	GB	of	RAM	might	need	no	page	file	and	a	computer	with	64	GB	of	RAM	might	need	a	huge	page	file.	It	all	depends	on	what	the	computer	is	doing.	Most	people	won’t	be	able	to	predict	how	much	paging	or	swap	space	they	need.	Even	if	you	looked	at	your	used	memory	right	now,	there’s	no	telling	how
much	your	programs	will	need	in	a	week	or	a	month.	Windows	Can	Automatically	Manage	It	On	Windows,	the	page	file	is	stored	at	C:\pagefile.sys.	By	default,	Windows	automatically	manages	the	size	of	this	file.	It	starts	small	and	grows	to	a	potentially	larger	size	if	you	need	it.	We	recommend	letting	Windows	handle	the	size	of	the	page	file	on	its
own.	It	shouldn’t	take	a	massive	amount	of	space	on	your	system	drive.	If	your	page	file	does	take	a	large	amount	of	space	on	your	system	drive,	it’s	because	you	needed	that	large	a	page	file	in	the	past	and	Windows	automatically	grew	it	in	size	for	you.	For	example,	on	a	Windows	8.1	system	with	only	4	GB	of	RAM,	our	page	file	is	currently	only	1.8
GB	in	size.	We	don’t	have	all	that	much	RAM,	but	Windows	is	using	a	small	page	file	until	we	need	more.	There	are	no	performance	benefits	to	getting	rid	of	a	page	file,	only	potential	system	instability	issues	where	programs	might	crash	if	you	use	all	your	RAM.	You	could	eliminate	the	page	file	to	save	space	on	your	system	drive,	but	it	usually	isn’t
worth	it.	If	you	want	to	manually	set	a	size	—	not	recommended	—	be	sure	to	bear	in	mind	that	what	really	matters	if	how	much	memory	your	system	will	use,	not	just	the	size	of	its	RAM.	Microsoft’s	documentation	notes	that:	“the	reason	to	configure	the	page	file	size	has	not	changed.	It	has	always	been	about	supporting	a	system	crash	dump,	if	it	is
necessary,	or	extending	the	system	commit	limit,	if	it	is	necessary.	For	example,	when	a	lot	of	physical	memory	is	installed,	a	page	file	might	not	be	required	to	back	the	system	commit	charge	during	peak	usage.	The	available	physical	memory	alone	might	be	large	enough	to	do	this.”	In	other	words,	it’s	all	about	how	much	memory	you’ll	actually	need
—	the	total	amount	of	available	memory	being	the	“system	commit	limit.”	Linux	Requires	a	Choice	RELATED:	How	to	Re-Enable	Hibernate	in	Ubuntu	12.04	On	Linux,	the	equivalent	to	the	Windows	paging	file	is	the	swap	partition.	Because	this	is	a	partition	and	not	just	a	file,	you	have	to	make	a	choice	about	the	size	of	your	swap	partition	when
installing	Linux.	Sure,	you	could	resize	your	partitions	later	—	but	that’s	more	work.	Linux	can’t	automatically	manage	the	size	of	your	swap	partition	for	you.	Each	Linux	distribution	uses	its	own	installer,	and	each	Linux	distribution	has	some	logic	in	its	installer	that	automatically	tries	to	choose	the	appropriate	swap	partition	size.	Linux	distributions
typically	use	the	size	of	your	RAM	to	help	decide	the	size	of	your	swap	partition.	When	installing	Ubuntu,	the	typical	default	swap	partition	size	seems	to	be	the	size	of	your	RAM	plus	an	additional	half	a		GB	or	so.	This	ensures	hibernate	will	work	properly.	If	you’re	manually	partitioning	in	your	Linux	installer,	the	size	of	your	RAM	plus	.5	GB	is	a	good
rule	of	thumb	that	will	ensure	you	can	actually	hibernate	your	system.	That	should	usually	be	more	than	enough	swap	space,	too.	If	you	have	a	large	amount	of	RAM	—	16	GB	or	so	—	and	you	don’t	need	hibernate	but	do	need	disk	space,	you	could	probably	get	away	with	a	small	2	GB	swap	partition.	Again,	it	really	depends	on	how	much	memory	your
computer	will	actually	use.	But	it’s	a	good	idea	to	have	some	swap	space	just	in	case.	The	old	“double	the	size	of	the	RAM”	rule	of	thumb	applied	to	computers	with	1	or	2	GB	of	RAM.	There’s	no	one-size-fits-all	answer	to	how	much	page	file	or	swap	space	you	need.	It	all	depends	on	the	programs	you	use	and	what	they	need.	If	you’re	unsure,	sticking
with	your	operating	system’s	defaults	is	almost	always	a	good	idea.	Image	Credit:	William	Hook	on	Flickr,	Jean-Etienne	Minh-Duy	Poirrier	on	Flickr	Did	you	just	download	a	PDF	file	containing	lots	of	pages	with	blank	or	filler	content?	You	probably	want	to	get	rid	of	them.	But	how?	Surprisingly,	it’s	not	that	complicated	to	delete	individual	pages	from
a	PDF.	So	below,	we	shall	walk	you	through	several	convenient	methods	to	delete	pages	from	a	PDF	on	any	desktop	or	mobile	device.	Use	Edge,	Chrome,	or	Firefox	(PC)	The	easiest	way	to	delete	individual	pages	from	a	PDF	file	on	your	PC	involves	using	nothing	more	than	a	web	browser.	The	procedure	consists	of	printing	the	contents	to	a	new	PDF
file	and	excluding	the	page	or	pages	you	don’t	want.	It	works	the	same	across	Microsoft	Edge,	Google	Chrome,	and	Mozilla	Firefox.	Start	by	dragging	and	dropping	the	PDF	file	into	your	web	browser	to	start	previewing	it.	Then,	select	the	Print	button	and	specify	the	page	ranges.	Make	sure	to	omit	the	page	or	pages	that	you	want	to	delete.		For
example,	if	you	want	to	delete	pages	6,	7,	9,	and	10	in	a	13-page	document,	type	in	1-5,	8,	11-13	into	the	Pages	field.	Then,	set	the	printer	to	Microsoft	Print	to	PDF	or	Save	as	PDF	and	select	Print	or	Save.	Use	PDF	X	(PC)	PDF	X	is	a	free	PDF	reader	and	editor	that	you	can	download	from	the	Microsoft	Store.	If	you	don’t	like	using	your	web	browser	to
interact	with	PDF	files,	you	can	use	PDF	X	instead	to	print	contents	to	new	files	without	any	pages	you	don’t	want.	While	viewing	a	PDF	in	PDF	X,	select	the	Print	icon	on	the	app’s	toolbar.	Then,	choose	Microsoft	Print	to	PDF	(or	any	other	PDF-related	printer)	as	the	printer,	specify	the	pages	you	want	to	print,	and	select	the	Print	button.	Use	the
Preview	App	(Mac)	The	Mac’s	native	Preview	app	makes	it	incredibly	convenient	to	delete	individual	pages	from	PDF	files.	Just	start	by	opening	the	PDF	in	Preview.	Then,	select	a	page	that	you	want	to	delete	from	the	sidebar	and	follow	that	by	selecting	Edit	>	Delete	to	get	rid	of	it.	You	can	also	select	multiple	pages	within	the	sidebar	while	holding
down	the	Command	key	and	delete	them	simultaneously.	To	save	the	changes,	select	File	>	Save.	If	you	want	to	keep	the	current	copy	intact,	hold	down	the	Option	key	and	choose	File	>	Save	as	to	save	the	contents	to	a	new	file.	In	addition	to	deleting	PDF	pages,	you	can	also	use	the	Preview	app	to	add	pages	to	documents,	annotate	files,	and	so	on.
Learn	how	to	get	the	most	out	of	Preview	on	Mac.	Use	the	Files	App	(iPhone	&	iPad)	If	you	have	an	iPhone	or	iPad,	you	can	use	the	built-in	Files	app	to	delete	select	pages	from	PDF	documents.	Start	by	tapping	on	the	PDF	within	the	Files	app	to	start	previewing	it.	Then,	tap	the	Share	icon	and	select	Print.	Follow	that	by	unchecking	the	pages	you
want	to	delete	from	the	preview	area	to	the	bottom	of	the	screen.		Next,	perform	a	pinch-out	gesture	on	a	page	thumbnail	page	to	enter	a	different	preview	screen.	Finally,	tap	the	Share	icon	again	and	tap	Save	to	Files	to	save	the	contents	of	the	modified	PDF	file	to	any	location	within	the	Files	app.	Use	Google	PDF	Viewer	(Android)	On	Android,	you
can	use	the	default	Google	PDF	Viewer	to	delete	pages	from	PDF	documents.	While	viewing	the	file,	tap	the	three-dot	icon	to	the	top-right	of	the	screen	and	select	Print.	Then,	uncheck	the	boxes	under	the	pages	you	want	to	delete,	set	the	printer	to	Save	as	PDF,	and	tap	the	Save	icon.	Note:	The	instructions	and	button	locations	above	may	change
between	Android	device	models	and	system	software	versions.	Use	Adobe	Acrobat	(Desktop	and	Mobile)	If	you	have	the	paid	version	of	Adobe	Acrobat	installed	on	your	desktop	or	mobile	device,	you	can	use	it	to	remove	any	page	from	a	PDF	quickly.	Adobe	Acrobat	–	Desktop	Open	the	PDF	in	Adobe	Acrobat,	switch	to	the	Tools	tab,	and	select	the
Organize	Pages	option.	Follow	that	by	selecting	the	Trash	icon	while	hovering	over	the	pages	that	you	want	to	delete.	You	can	then	select	File	>	Save	to	save	the	changes	to	the	same	file,	or	File	>	Save	As	to	create	a	new	copy	of	the	modified	document.	Adobe	Acrobat	–	Mobile	Open	the	PDF	in	Adobe	Acrobat.	Then,	select	the	three-dot	icon	to	the
top-right	of	the	screen.	On	the	set	of	tools	that	show	up,	choose	Organize	Pages.		Next,	mark	the	pages	that	you	want	to	delete	and	tap	the	Trash	icon.	Finally,	tap	Done	to	save	your	changes.	Use	an	Online	PDF	Tool	(Desktop	and	Mobile)	If	you’re	in	a	hurry	and	don’t	have	the	time	to	mess	around	with	menus,	toggles,	and	print	options,	you	can	resort
to	using	an	online	PDF	tool	to	delete	pages	from	a	PDF	document.	Smallpdf,	for	example,	allows	you	to	upload	and	remove	pages	using	its	Delete	PDF	Pages	tool.	You	can	then	download	the	modified	PDF	file	to	local	storage.	Other	tools	such	as	Sejda	and	PDF2GO	also	work	the	same.	However,	almost	every	online	tool	has	restrictions	that	prevent	you
from	uploading	or	processing	multiple	files	unless	you	upgrade	to	a	paid	plan.	Also,	it’s	best	to	avoid	uploading	PDF	files	with	sensitive	information	online.	Lightweight	and	Clutter-Free	PDFs	Deleting	unwanted	pages	from	PDFs	helps	reduce	clutter	and	improves	readability.	But	unless	you	already	pay	for	a	dedicated	PDF	editor	such	as	Adobe
Acrobat,	sticking	to	the	native	methods	listed	above	should	work	just	fine.
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